Jalin Merapi on BlackBerry®


Compatible with OS: 4.6, 4.6.1, 4.7.0, 5.0.0, 6.0.0
Compatible for devices: 8520, 8900, 9000, 910x, 9300, 95xx, 96x0, 9700, 9800

Get the app now, click here to download.



*installation guidance or feedback: mail @ 7Langit.com

[1] 7Langit provide the program without warranty of any kind.
[2] By installing Jalin Merapi on BlackBerry® you agree to receive notifications from the application.